Page 1 of 1

(Probably) a WorldGuard error.

Posted: Fri Jan 03, 2020 7:39 am
by xCustomWorld

Code: Select all

org.bukkit.command.CommandException: Unhandled exception executing command 'herobrine' in plugin Herobrine v2.0.1
	at org.bukkit.command.PluginCommand.execute( ~[patched_1.15.1.jar:git-Paper-32]
	at org.bukkit.command.SimpleCommandMap.dispatch( ~[patched_1.15.1.jar:git-Paper-32]
	at org.bukkit.craftbukkit.v1_15_R1.CraftServer.dispatchCommand( ~[patched_1.15.1.jar:git-Paper-32]
	at org.bukkit.craftbukkit.v1_15_R1.CraftServer.dispatchServerCommand( ~[patched_1.15.1.jar:git-Paper-32]
	at net.minecraft.server.v1_15_R1.DedicatedServer.handleCommandQueue( ~[patched_1.15.1.jar:git-Paper-32]
	at net.minecraft.server.v1_15_R1.DedicatedServer.b( ~[patched_1.15.1.jar:git-Paper-32]
	at net.minecraft.server.v1_15_R1.MinecraftServer.a( ~[patched_1.15.1.jar:git-Paper-32]
	at ~[patched_1.15.1.jar:git-Paper-32]
	at [?:1.8.0_202]
Caused by: java.lang.NullPointerException
	at ~[patched_1.15.1.jar:git-Paper-32]
	at com.sk89q.worldedit.util.Location.<init>( ~[?:?]
	at com.sk89q.worldedit.util.Location.<init>( ~[?:?]
	at ~[?:?]
	at net.theprogrammersworld.herobrine.Support.isSecuredArea( ~[?:?]
	at net.theprogrammersworld.herobrine.Support.checkHaunt( ~[?:?]
	at net.theprogrammersworld.herobrine.commands.CmdHaunt.execute( ~[?:?]
	at net.theprogrammersworld.herobrine.commands.CmdExecutor.onCommand( ~[?:?]
	at org.bukkit.command.PluginCommand.execute( ~[patched_1.15.1.jar:git-Paper-32]
	... 8 more

This error happens everytime I use any Herobrine command where WorldGuard checks are used. I'm using GriefDefender 1.2.3 with WE 7.1.0-BETA and WG 7.0.1. Looks like the plugin is either not adapted to WG or GriefDefender. GriefDefender is plugin that basically combines GriefPrevention and WG into a new, better plugin (

I'm using PaperSpigot build 32 for MC 1.15.1, downloaded from

My config.yml:

Code: Select all

  ShowInterval: 144000
  ShowRate: 2
  HitPlayer: true
  SendMessages: false
  Lightning: false
  DestroyTorches: true
  DestroyTorchesRadius: 5
  - Survival
  TotemExplodes: true
  OnlyWalkingMode: false
  BuildStuff: true
  PlaceSigns: true
  UseTotem: true
  WriteBooks: true
  Killable: false
  UsePotionEffects: true
  CaveChance: 40
  BookChance: 5
  SignChance: 5
  - Hælp
  - ...
  - Hi
  - are u ready‽
  - im waiting...
  - dont look behind
  - ...
  - death
  - are you sure?
  - you cant escape...
  - ...
      count: 1
      chance: 20
  BuildPyramids: true
  BuildPyramidOnChunkPercentage: 5
  UseGraveyardWorld: false
  BuryPlayers: true
  SpawnWolves: true
  SpawnBats: true
  UseWalkingMode: true
    X: 5000
    Z: 5000
    FromX: 0
    FromZ: 0
  BuildInterval: 72000
  BuildTemples: false
  BuildTempleOnChunkPercentage: 5
    Bow: false
    Sword: false
    Apple: false
  HerobrineHP: 300
  AttackCreative: true
  AttackOP: true
    Build: false
    Attack: false
    Haunt: false
    Signs: falss
    Books: false
  UseHeads: true
  UseAncientSword: false
    Guardian: true
    Warrior: true
    Demon: true
  SpawnDemonsOnPlayerBedEnter: true
  ItemInHand: AIR
  Explosions: true
  Burn: true
  Curse: true
    Books: 1
    Signs: 1
    Heads: 1
  UseIgnorePermission: true
  HerobrineUUID: 0000000-6660-abdc-0666-00000000000
  HerobrineName: Herobrine
  HerobrineWorldName: graveyard
  ShowInTabList: false
  CheckForUpdates: true

If you need more details, I'm able to provide them. I know you are fixing just critical bug because of lack of your spare time, but this seems critical enough, as it makes Herobribe at my server unusable. I don't know if there is a problem on your side or on my side, but I'd be happy with every assistance to get this bug fixed. Thank you.

Re: (Probably) a WorldGuard error.

Posted: Fri Jan 03, 2020 10:09 pm
by David B
I am very confident that this issue has to do with your use of a modified WorldGuard version, as the original WorldGuard works just fine in my testing. I would recommend using that version instead. I would have tried to add support for this plugin, but unfortunately, it is not a free plugin and therefore, I am unwilling to do so.

Re: (Probably) a WorldGuard error.

Posted: Sat Jan 04, 2020 7:03 pm
by David B
Hello xCustomWorld,

When Herobrine v2.0.2 comes out, you may want to try it, as I believe it may solve the problem you were having.

Thank you,

Re: (Probably) a WorldGuard error.

Posted: Sun Jan 05, 2020 9:18 am
by xCustomWorld
Thank you, it works now.

Re: (Probably) a WorldGuard error.

Posted: Sun Jan 05, 2020 4:24 pm
by David B
xCustomWorld wrote:
Sun Jan 05, 2020 9:18 am
Thank you, it works now.
You're welcome! Thanks for verifying that for me.